Jump to content



Photo

Toshiba WX-1


  • This topic is locked This topic is locked
16 replies to this topic

#1 Jwrok707

Jwrok707
  • Members (SA)
  • 689 posts
  • LocationToronto

Posted 31 January 2011 - 10:16 PM

About a month ago I picked up a WX-1, and man is this NICE!!!!!! Just wondering if the VU meters are supposed to have functioning lights?

#2 redbenjoe

redbenjoe

    I Am Legend

  • Eternal Order of Boom
  • 17,995 posts
  • Locationflorida

Posted 31 January 2011 - 11:56 PM

tremendous power :yes: :yes:

and - yes - both meters have strong lights

#3 baddboybill

baddboybill
  • Boomus Fidelis
  • 10,991 posts
  • LocationHudson Florida

Posted 01 February 2011 - 12:24 AM

:morepics: :morepics: :morepics:

#4 bigolac

bigolac
  • Members (SA)
  • 37 posts
  • LocationWisconsin

Posted 05 February 2011 - 07:39 PM

:morepics: :morepics: :morepics:



+1!!!

- Adam

#5 Jwrok707

Jwrok707
  • Members (SA)
  • 689 posts
  • LocationToronto

Posted 05 February 2011 - 11:24 PM

I'm sorry about no pics, I've tried but can't seem to be able to get my pics or avatar posted! I'm a rookie, may need some help.

#6 baddboybill

baddboybill
  • Boomus Fidelis
  • 10,991 posts
  • LocationHudson Florida

Posted 06 February 2011 - 12:22 AM

I'm sorry about no pics, I've tried but can't seem to be able to get my pics or avatar posted! I'm a rookie, may need some help.

For uploading pics off your computer just click the ( here to upload images) then press ( select files) then find pictures click on and it uploads..once you see the img. code in 2nd box to right hit ( add link codes to post.) ..That easy :-D As for avatar it cant be larger than maybe 600x800 I think :hmmm: :hmmm:

#7 Jwrok707

Jwrok707
  • Members (SA)
  • 689 posts
  • LocationToronto

Posted 08 February 2011 - 03:28 PM

Hey badboybill, bigolac sorry for the absent photos, Im pretty slow when it comes to this "COMPUTER" thing, I think I was able to get these to post, hopefully this is not another test run.

#8 monchito

monchito
  • Boomus Fidelis
  • 4,601 posts
  • Locationpythonville florida

Posted 08 February 2011 - 03:31 PM

tremendous power :yes: :yes:

and - yes - both meters have strong lights

:agree: :agree: :agree: and a green background on the radio dial :yes: :yes: :yes:

#9 Jwrok707

Jwrok707
  • Members (SA)
  • 689 posts
  • LocationToronto

Posted 08 February 2011 - 03:33 PM

Sorry, MY BAD, ill get this thing figured out one day!

Posted Image

Posted Image

Posted Image

Posted Image

Posted Image

#10 kingrat2010

kingrat2010
  • Members (SA)
  • 2,192 posts
  • Locationaustria west

Posted 08 February 2011 - 03:42 PM

:drool: :drool: :drool:

#11 skippy1969

skippy1969
  • Boomus Fidelis
  • 4,536 posts
  • LocationBaraboo Wisconsin

Posted 08 February 2011 - 03:48 PM

Thats a real beauty!!!!!!!!! :drool: :drool: :drool: :drool: :drool: :drool: :drool:
I would love to have one .......someday........... :thumbsup: :thumbsup:

#12 monchito

monchito
  • Boomus Fidelis
  • 4,601 posts
  • Locationpythonville florida

Posted 08 February 2011 - 04:36 PM

me two :-D :-D :agree:

#13 sony_apm_fan

sony_apm_fan
  • Members (SA)
  • 1,142 posts
  • LocationAustralia

Posted 08 February 2011 - 04:39 PM

Great looking box, would be proud to have one :-)

#14 Jwrok707

Jwrok707
  • Members (SA)
  • 689 posts
  • LocationToronto

Posted 08 February 2011 - 04:54 PM

I must apologize for the quality of pictures, as they were taken from my phone.
Thanks for the response!!!!!!

#15 Jboogie2384

Jboogie2384
  • Members (SA)
  • 1,267 posts
  • LocationQueens, New York

Posted 02 March 2011 - 03:02 PM

Welcome to the Wx-1 club. Your speakers look a little different from mine. I'll put up pix later or you can check my posts and see. Yea the lights are nice and bright too. She pounds really nice.

Posted Image

Posted Image

#16 hemiguy2006

hemiguy2006
  • Members (SA)
  • 2,306 posts

Posted 03 March 2011 - 05:21 PM

Congrats on the WX-1 these are a great quality box!!!
Good luck replacing those bulbs these are not the easiest boxes to work on / dis-assemble :sadno:

#17 Jwrok707

Jwrok707
  • Members (SA)
  • 689 posts
  • LocationToronto

Posted 03 March 2011 - 07:49 PM

Yeah thanks for the Heads Up, I still got to get it to my tech guy to go over it for me. I totally agree with you guys, I have a few boxes and I am really glad I picked this one up, ITS A MONSTER!