Jump to content



Photo

JVC RC-656


  • This topic is locked This topic is locked
3 replies to this topic

#1 Brownlow

Brownlow
  • Members (SA)
  • 252 posts

Posted 20 November 2010 - 03:06 PM

Greetings Everyone,

I picked this unit up a bit over a couple of months ago. It is a lovely sounding mid-powered unit, probably about 5W / ch. I would like to get the cassette working hassle free. Two issues prevail;

1. Playing a cassette tape from the beginning, it will eventually begin to slow down and then stop when it gets to the middle or the end of the tape. The FF and REW functions work unhindered. The sound partially takes on a 'flanging' character when it reaches the middle to end of cassette tape.

2. There is a hum that can be heard when a cassette tape is played. The hum registers on the LEDs and is above music level. This occurs when the motor is moving and no hum exists when listening to radio. I feel like it might be a faulty capacitor near motor section, but I am not 100% certain.

Is anyone familiar with this boombox and the issue? Is there a service manual for the RC-656 that someone has access to?

I would be most grateful if someone could provide me with a few pointers. It's a nice unit.

Cheers.

Brownlow

#2 monchito

monchito
  • Boomus Fidelis
  • 4,601 posts
  • Locationpythonville florida

Posted 20 November 2010 - 03:42 PM

hi i have found and this is not all the time if you deoxit the record bar that might take care of some sound issues ,, the deck would be good to check the belts they well be in need of replacing so thats basicly a starter ,, :-) :-) :-)

#3 Brownlow

Brownlow
  • Members (SA)
  • 252 posts

Posted 20 November 2010 - 04:33 PM

Hi Monchito,

Thanks for the reply. I think the belt feels like it could be a little loose. It's probably a good idea to replace belts as these machines are about 30 years old or more. Do you know where I can get belts for this unit. I have tried a couple places, the response is either NLA or no reply to email (encompass and ued was where I had enquired, I've avoided Partstore as its reputation here at Boomboxery is legendary....).

You also mentioned the record bar, I'm a bit unclear as to what this is.

Cheers


Brownlow

#4 Brownlow

Brownlow
  • Members (SA)
  • 252 posts

Posted 22 November 2010 - 10:19 AM

Hi,

Things seem to have taken a backward step, the sound is more like some sort of, I dunno, ripple. It comes through the left speaker (I've now listened to it a bit better). There are no issues with audio through the radio.

Does anyone have a Service Manual for this unit, also a replacement belt (as per Monchito's recommendation).

Any more ideas would be appreciated.

Cheers


Brownlow