Jump to content



Photo

JVC PC-W330


  • Please log in to reply
2 replies to this topic

#1 Malkozaine

Malkozaine
  • Members
  • 2 posts

Posted 12 September 2019 - 11:39 AM

So as a tech project I bought a JVC PC-W330. It mostly works save for the tape decks. For what I can get working right now it sounds amazing. It needs new speaker cables, but thank God I have some so that will be easy. My big issue is the tape decks don't work at the moment. Both play buttons are stuck down and the doors won't open. As far as I can tell from a ton of online searching the main issue might be the two main drive belts are to old and lose thus aren't spinning the flywheels needed to run the tape deck. Thus the system is stuck in a "play" position and doesn't allow the stop/eject buttons to work right. Getting to the belts, finding them online, and replacing them so far are turning out to be or will be a massive pain in the ass. Anyone have any advice or suggestions, thanks for any help you might be able to give.

#2 JVC Floyd

JVC Floyd
  • Boomus Fidelis
  • 6,566 posts

Posted 13 September 2019 - 11:34 AM

Hi if you post pics of what you're working on then it'll be a big help plus investing maybe $20 in some pics to Loop the belts around the flywheels if they're hard to reach it may be a small magnet make sure you collect all the screws up and only tear the decks down as far as you have to go to make it only a reasonably massive pain in the ass without going any farther so it's less work putting it back together you can buy various belt packs with different size belts in them from www.dot Studio sound Electronics. Com.

Usually these belt packs have belts in them that fit almost anything but if you have to do two Decks then you need to buy two identical variety packs of belts.

#3 Malkozaine

Malkozaine
  • Members
  • 2 posts

Posted 13 September 2019 - 02:01 PM

My bad I forgot to get pictures of it. I will try to post some later tonight or tomorrow.