Jump to content



Photo

Noisy Right Channel in Tape Mode - Sanyo M9994K


  • Please log in to reply
3 replies to this topic

#1 ElectroKid

ElectroKid
  • Members (SA)
  • 51 posts

Posted 27 August 2019 - 09:38 AM

Hi all,

Strange ambient constant noise and intermittent loud pop noises/bursts occur only in Tape mode, and only in Right channel.
(noise volume changes with volume adjustment).
When using Mono mode, the 2 channels are mixed - this can confuse to think the issue is common to both cahnnels as it gives identical sound in both speakers - so I am using the Stereo mode which isolated the problem to R-ch only:

 

 

Engaging the Record bar makes it silent, but upon releasing, all the above noises fade-in and come back.
There are some 100+ e-caps in the main board, but I'd like to pinpoint the offending caps or components rather than tediously recapping only to find no change.
So far, ALL the caps pulled/swapped were in spec and ESR.

Actions taken to no affect:
1) Tapehead demag
2) Mode switch cleaned (Tape/Radio/Line-in)
3) Volume pot cleaned (which took away crackles DURING volume adjusting, not related to issue)
4) Rec bar sprayed with DeOxit D5 (not sure it penetrates enough tho...)
Note, the noises occur without a mech movement, so pretty sure the rec bar isn't to blame here.
5) Tapehead wires, GND connection and misc interconnections/jumpers verified as good
6) R-ch path e-caps and BJT transistors replaced up to mode switch (see highlighted audio path in pic)

Any suggestions appreciated.
(can post the whole Sanyo M9994K Service Manual pdf, if needed)

Cheers
Attached File  R-ch audio path highlighted.jpg   111.54K   5 downloads



#2 caution

caution
  • Members (SA)
  • 1,926 posts
  • LocationHillsboro, Oregon

Posted 07 November 2019 - 04:29 PM

Did you figure this out?



#3 ElectroKid

ElectroKid
  • Members (SA)
  • 51 posts

Posted 08 November 2019 - 11:00 AM

No, it remains unsolved.
Reassembled the box, decided this issue not worth anymore tinkering at this point.
It sounds like some 'electronic zapping' hits, not from outside radiation, same happens on batteries.

Other issue that may be related and is more important to tackle is a weak FM tuner, stations come in weak, but touching the anttena with hand, the tuning strengh needle moves up, volume goes up and there's less static.
Aging caps as usual come to mind but still am not convinced I should recap.
Do you have a good cap meter and esr meter to recommend?

#4 Superduper

Superduper
  • Boomus Fidelis
  • 6,846 posts
  • LocationSomewhere over the rainbow, USA

Posted 08 November 2019 - 11:31 AM

The record bar is typically a bigger source of issues than most folks give credit for.  It is absolutely imperative that one clean it well which I know is not easy.  The best way I've found is to stand the frame up in such a way that the bar is vertical, then spray cleaner into the top end (bottom edge of lever closest to the pcb) and work the bar vigorously and hopefully, watch the solvent come out the other end.  Be generous and clean up afterwards with zero residue electronics cleaner.

 

Capacitance rarely changes much on caps unless they have failed 100%.  Testing old caps, I find that the capacitance is often higher than new ones.  ESR on the other hand is important but even more iimportant is leakage.  Caps are supposed to block DC but as they get old, they often become quite leaky which can lead to DC in the audio circuit which you DO NOT WANT.  It can even change the bias levels for the transistor amps in the signal path.  Capacitors are so cheap that I suggest if you go so far as to remove one from circuit, put in a new one and not the 40 year old original back in.  Unless you do this for a living, it's absolutely not worth it to purchase a capacitor tester that is any good.  They cost a ton of money.  You can probably recap every single piece of gear you own and still come out ahead compared to purchasing a true lab quality tester.  I have an old Sencore capacitor analyzer.  It's like 40 years old.  New ones of those quality are really cost prohibitive and these used ones are really hit and miss...  how will you know after 40 years, it's still accurate?

 

As for FM, sanyos are known for weak tuners over time.  I'm not sure if yours is related to alignment drift or weakness in the transistor amps but replacements with the same characteristics are really hard to find replacements for plus you'll probably have to realign again after replacement.  You can try replacing the e-caps in the tuner but I highly doubt that it will make any difference.  First there are relatively few e-caps in a tuner and they are only used in non-critical locations.  All caps that have effect on tuner will be styrol, ceramic, etc and they rarely fail.