Jump to content



Photo

PIONEER SK-21 does not recording


  • Please log in to reply
6 replies to this topic

#1 ooss

ooss
  • Members
  • 2 posts

Posted 15 August 2019 - 12:32 PM

Hi guys! I have PIONEER SK-21 and I repairing it.
I was cleaning it, changed belts. All works fine right now except recording. 
​When I push the record button boombox starting play, not recording. See video..
I have no idea why recording not working. What do you think? Have you any idea?

 



#2 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 5,242 posts
  • LocationChicago, IL

Posted 15 August 2019 - 05:07 PM

 

Hi guys! I have PIONEER SK-21 and I repairing it.
I was cleaning it, changed belts. All works fine right now except recording. 
​When I push the record button boombox starting play, not recording. See video..
I have no idea why recording not working. What do you think? Have you any idea?

 

 

 

First thing to do is clean the long record bar switch inside the boombox. You cannot miss it because it is the longest bar switch on the circuit board.

Spray Deoxit contact cleaner from both ends of it, any holes you see on the top of the switch and manually move it by pushing the end of the switch. Push it a minimum 25 times. Wait for say 10 minutes and try recording. 



#3 Superduper

Superduper
  • Boomus Fidelis
  • 6,849 posts
  • LocationSomewhere over the rainbow, USA

Posted 15 August 2019 - 05:43 PM

I suspect that the record lever connecting the mechanism to the record bar was not replaced properly.

#4 Fatdog

Fatdog
  • Administrators
  • 10,806 posts
  • LocationMiddle Tennessee, U.S.A.

Posted 15 August 2019 - 06:52 PM

I suspect that the record lever connecting the mechanism to the record bar was not replaced properly.

That was my first thought also.  :yes:  I've been guilty of that.



#5 goodman

goodman
  • Members (SA)
  • 1,869 posts
  • LocationBulgaria

Posted 17 August 2019 - 07:54 AM

I agree that have a mechanical problem:
When push rec button, play button make little jump.
This is a problem...



#6 baddboybill

baddboybill
  • Boomus Fidelis
  • 10,986 posts
  • LocationHudson Florida

Posted 17 August 2019 - 08:34 AM

I agree that have a mechanical problem:
When push rec button, play button make little jump.
This is a problem...


Actually Play has to be in mode in order for record mode to fully work. What the record button does is engage the record switch and that is what seems to be issue

#7 iplapa

iplapa
  • Members
  • 6 posts
  • LocationRussia

Posted 24 September 2019 - 10:58 PM

Проверить?

Attached Files