Jump to content



Photo

Rc m90 cassette deck issue


  • Please log in to reply
7 replies to this topic

#1 squeeezebox

squeeezebox
  • Members (SA)
  • 37 posts
  • LocationWindsor England

Posted 16 February 2019 - 05:49 PM

Can anyone help with this, the cassette deck does not work on my m90, no sound from motor, no mechanical sound from anything. There is a clunking sound for 2 seconds everytime you switch on the power switch but nothing more.

#2 Rimmer36

Rimmer36
  • Members (SA)
  • 3,225 posts

Posted 16 February 2019 - 06:42 PM

belts, do not use like this, you will burn out the deck safety resistors

 

belts can be had here

https://www.ebay.co....W-bN6:rk:1:pf:1



#3 squeeezebox

squeeezebox
  • Members (SA)
  • 37 posts
  • LocationWindsor England

Posted 16 February 2019 - 07:16 PM

Great, thank you, can you explain what is it doing?

#4 Rimmer36

Rimmer36
  • Members (SA)
  • 3,225 posts

Posted 16 February 2019 - 08:06 PM

it seems to me the deck is ok (i could be wrong) but done this many times, when you first turn on the m90 you get a clunk, this is a deck check and done by the main motor that drives the main capstan, this tells me the main motor should be ok. anyway dude if you go on to the main tech section you will find everything you need to know about the m90, good  luck

 

here we go  :-)

 

https://boomboxery.c...orum/44-rc-m90/



#5 squeeezebox

squeeezebox
  • Members (SA)
  • 37 posts
  • LocationWindsor England

Posted 16 February 2019 - 10:53 PM

Thanks ive read back through the forums, there seems to be a lot of good info regarding this issue.

#6 prg333

prg333
  • Members (SA)
  • 110 posts

Posted 10 December 2019 - 07:41 AM

belts, do not use like this, you will burn out the deck safety resistors

 

belts can be had here

https://www.ebay.co....W-bN6:rk:1:pf:1

are the safety resistors AKA fusible resistors 



#7 docs

docs
  • Members (SA)
  • 1,923 posts
  • LocationUnited Kingdom

Posted 10 December 2019 - 08:05 AM

 

belts, do not use like this, you will burn out the deck safety resistors

 

belts can be had here

https://www.ebay.co....W-bN6:rk:1:pf:1

are the safety resistors AKA fusible resistors 

 

 

yes, 4.7, 10, 2.2 and 1.5 all 1/4W.



#8 Newclairtone7980

Newclairtone7980
  • Members (SA)
  • 43 posts
  • Locationontario

Posted 12 December 2019 - 09:35 PM

hi yes its your tape belts need to be replaced another way to check  is  put a tape in the deck when it is turned on  then power it  off with the tape inside if it does now click your tape belts are bad   the m90 does a reverse function. with tape in... so when a tape is in and you turn power on it will not cllunk.   but it does when you turn it off  easy fix.............good luck