Jump to content



Photo

Panasonic RX-CS780 help


  • This topic is locked This topic is locked
2 replies to this topic

#1 Captain Wrong

Captain Wrong
  • Members
  • 2 posts

Posted 29 April 2018 - 07:38 AM

Hey, I recently got a RX-CS780 and I’m having a bit of a time with it. One of the cassette belts had disintegrated so I got what I thought were the right ones. Put it back together and it was running way too slow. Opened it back up and somehow I knocked a cable off and now I’m getting nothing. For the life of me, I can no figure out where this goes. Hope this picture shows what I’m talking about. Also if anyone can help me with how the belts are supposed to run, that would help too. (I thought I had them right, but I was flying blind since the old ones were broken.) Thanks in advance for any help.

Attached Files



#2 JVC Floyd

JVC Floyd
  • Boomus Fidelis
  • 6,566 posts

Posted 29 April 2018 - 02:28 PM

Shine a light onto the deck and look for a hole within the proximity of the wire length that the leaf switch is attached to , that switch is activated by the movement of parts in the deck so if you work the deck up and down and look for a flat spot that is missing a leaf switch.

#3 Captain Wrong

Captain Wrong
  • Members
  • 2 posts

Posted 30 April 2018 - 04:35 PM

Unfortunately in the process of getting it where I thought it needed to go, I broke the switch off the wires. So now I'll have to see about re-soildering it and I still don't think I found where that switch goes. Ah well, that's the kind of month I've been having. lol