Jump to content


Photo

New GF 777 - pots and right channel speakers doesn't work

777 sharp gf 777

  • Please log in to reply
5 replies to this topic

#1 pimpkie

pimpkie
  • Members
  • 21 posts
  • Locationfrance

Posted 30 December 2017 - 05:43 PM

 Hi everyone ... i just got a new 777 a couple of days ago but with some troubles to come with...

all the potties side (from ECHO to BALANCE ) don't work at all .

and the both right channel speakers doesn't work either (can hear a lil sound when MAIN VOLUME pot is turned a little bit but comes up with scratchy noise on all the speakers ) so i changed the speakers but obviously that didn't change anything.

 

I also cleaned up the PHONO/LINE OUT swicth on the back with some electronic spray

 

so i think i need to clean up all those damned potties from the inside.

the thing is that boombox is my second one and i don't want to mess with it again like the previous one so i need your help one more time to tell me how to clean everything that could make this baby work again without destroying it.

 

Rather than take away the potties part and start to dismantle 'em one by one i wanna know if there is another way to clean'em and the proper way to do so .. can i use a toothbrush with a electronic spray if i have no choice but to open'em ?

 

Tell me please if i have to check the power amp caps or any other one on other boards

 

This thing has the both tape working in any ways from the REC to the APLD system and the tuner has a good reception for french radio stations,only the potties sections doesn't respond at all and has some sticky yellowish kinda glue and some pretty discusting dust inside so i have to clean em 

 

I learned a lot when all of you helped me back then and i want to thank you a lot for everything you did for me so far!!!!

                     

                           THANKKKKKSSSSSS AND HAPPY NEW YEAR / BONNE ET HEUREUSE ANNEE A TOUS!!!!!!



#2 JVC Floyd

JVC Floyd
  • Boomus Fidelis
  • 5,166 posts

Posted 30 December 2017 - 05:47 PM

I saw a full set of pots on eBay for a reasonable price .
just search for sharp boombox parts in the search window.

#3 T-STER

T-STER
  • Members
  • 1,432 posts
  • LocationUK

Posted 31 December 2017 - 04:25 AM

I would be tempted to clean all pots first Inc record bar before any dismantling. There was a great post recently on cleaning pots. Get some deoxit in am all first.

#4 Cpl-Chronic

Cpl-Chronic
  • Members
  • 1,890 posts
  • LocationWindsor, Ontario, CANADA

Posted 31 December 2017 - 01:25 PM

I had trouble with the Line-In/Phono switch & had to solder the pads so it works on Line-In only but if the problem is the same on radio & tape then it's not the switch in the back....



#5 pimpkie

pimpkie
  • Members
  • 21 posts
  • Locationfrance

Posted 31 December 2017 - 02:49 PM

I had trouble with the Line-In/Phono switch & had to solder the pads so it works on Line-In only but if the problem is the same on radio & tape then it's not the switch in the back....

yes indeed it's not that line out phono switch that makes the boombox having issues :::though i guess the issues come from the potties section or the power amp section......but if anyone or you having that same speakers problems .... please let me know you manage to fix it....



#6 pimpkie

pimpkie
  • Members
  • 21 posts
  • Locationfrance

Posted 03 January 2018 - 11:01 AM

mission acomplished:::i managed to fix the potties part wihout dismantle the whole part from the inside ::::

but some of the potties lacks of grease because of the contact spray so when i squeeze em it it's kind a weird 

i wanna know if it's dangerous ? thanks 





Also tagged with one or more of these keywords: 777, sharp gf 777