Jump to content


Photo

New to me Sharp GF 8585 E


  • Please log in to reply
5 replies to this topic

#1 c bank

c bank
  • Members
  • 51 posts
  • LocationManchester UK

Posted 04 December 2017 - 05:04 PM

So if you read my introduction you'll know ill have my second box in  errrm.. 35 years  :yes: a Sharp GF 8585 E.

Cosmetically, it pretty good but will need a thorough detox and spit and polish.. any tips for cleaning the silver painted plastic? How about isopropyl alcohol ?

The radio works fine and the cassette rewinds and fast forwards OK but wont play. Any ideas? 

im no expert (as in never done anything like this before) but id like to have a crack at doing the work myself partly for the interest and partly to keep the budget realistic. 

 

Any tips or info greatly appreciated  :rock:



#2 T-STER

T-STER
  • Members
  • 1,434 posts
  • LocationUK

Posted 05 December 2017 - 12:49 AM

The Sharp issue of fwd and crew but no play is usually caused by a little capstan tyre disintegrating. If you look where the flywheel pin goes through you will see a small housing on the front of the deck holding a little rubberpiece of tubing which is always rotted out. I use either some rc fuel line or a little soft rubber bead thing.

There are plenty of vids on it, it's not difficult. Just cut the fuel line as close to original size as possible, clean and lube all transport as you go.

If you need some sent let me know, I have enough to do several hundred boxes...

#3 c bank

c bank
  • Members
  • 51 posts
  • LocationManchester UK

Posted 05 December 2017 - 02:51 AM

Thanks for the heads up and kind offer T STER... I will certainly take you up on that if mine has failed. Will it be obvious if mine HAS failed ? please bare in mind this is all new to me and I don't know the intricacies of these things but I have the enthusiasm and Can't wait to get stuck in ... hopefully at the weekend .. you mention a video on the subject ..is that a generic video on the procedure or specific to my model ?
I can't find a video covering my model.

#4 T-STER

T-STER
  • Members
  • 1,434 posts
  • LocationUK

Posted 05 December 2017 - 12:08 PM

The capstan tyre issue is unique to a lot of sharp models, i think i even have deck from that box here from a parts box I had so may be able to help with pictures etc. Yours will certainly have failed as they all have at this stage pretty much. Unless it has been stored really well.

Let me know when it arrives and I will help any way I can.

#5 jimmyjimmy19702010

jimmyjimmy19702010
  • Members
  • 3,162 posts
  • LocationSunny Brisbane, Australia

Posted 05 December 2017 - 11:21 PM



#6 c bank

c bank
  • Members
  • 51 posts
  • LocationManchester UK

Posted 06 December 2017 - 02:04 AM

The capstan tyre issue is unique to a lot of sharp models, i think i even have deck from that box here from a parts box I had so may be able to help with pictures etc. Yours will certainly have failed as they all have at this stage pretty much. Unless it has been stored really well.
Let me know when it arrives and I will help any way I can.


Nice one T STER ! :-)


Thanks fir that jimmy I'll have a watch later.