Jump to content


Photo

Volume issue with RC 828


  • Please log in to reply
4 replies to this topic

#1 Narhito

Narhito
  • Members
  • 5 posts

Posted 01 August 2017 - 01:02 PM

Hi everyone,

Recently picked up this RC 828, and i am having a hell of a time with the volume.  The volume sliders don't work at all and the volume is cranked up!  Sounds great, but its too loud.

 

I've been picking up boxes in the past little while, but still new to tinkering with them.

 

Any ideas on how to fix this?  Sorry if this is a real basic question.

 

Attached File  IMG_0016.JPG   111.67K   2 downloads

 

Attached File  IMG_0019.JPG   88.28K   0 downloads



#2 Northerner

Northerner
  • Members
  • 4,007 posts
  • LocationNorth East UK

Posted 01 August 2017 - 01:08 PM

Tried switch cleaner yet? This clears up a lot of these issues

Great box by the way, they sound great when they're working

#3 stevenrob

stevenrob
  • Members
  • 167 posts
  • LocationFrance, North

Posted 01 August 2017 - 01:41 PM

hello, all the JVc biphonic have a problem with pots. 



#4 ELzekio

ELzekio
  • Members
  • 15 posts

Posted 03 August 2017 - 06:39 AM

It may be best if you did a total rebuild of the sliders, not just spray with deoxit. There is likly to much dirt for the Deoxit. You will also disolve the silicone grease lube by spraying that stuff in there.

#5 T-STER

T-STER
  • Members
  • 1,424 posts
  • LocationUK

Posted 03 August 2017 - 06:42 AM

It may be best if you did a total rebuild of the sliders, not just spray with deoxit. There is likly to much dirt for the Deoxit. You will also disolve the silicone grease lube by spraying that stuff in there.

I think deoxit should be the first option, using F5 also doesn't leave them too scratchy. Dismantling and rebuilding the sliders should be a last resort as it is easy to damage them and with metal fatigue you really only get one chance.