Jump to content


Photo

Panasonic 5250 popping noise

popping speaker problems

  • Please log in to reply
5 replies to this topic

#1 FRizzo17

FRizzo17
  • Members
  • 16 posts

Posted 02 June 2017 - 04:40 PM

I have a 5250 and when i put on radio or tape player i get this popping sound and cant hear the music. Its the left side only. I tried the usual methods of deoxit in the record bar and function switches but still nothing. I un soldered the speaker and tried a different one but same problem. If any one can give me multiple answers as to what it may be, that would be appreciated. I also tried to press record with a blank tape but it makes that sound even when record is pressed. So i just left the left side unsoldered and can here the left channel now. Any solutions/ideas?



#2 Reli

Reli
  • Boomus Fidelis
  • 4,626 posts
  • LocationUSA

Posted 02 June 2017 - 06:22 PM

Do you mean a repeating pop, or a single pop?



#3 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,801 posts
  • LocationChicago, IL

Posted 03 June 2017 - 07:25 AM

It could be a bad capacitor! Check the main board for any swollen capacitors. 



#4 baddboybill

baddboybill
  • Boomus Fidelis
  • 10,658 posts
  • LocationIn the middle of nowhere!!

Posted 03 June 2017 - 09:55 AM

Did you try cleaning the headphone jack?

#5 HRmeteohub

HRmeteohub
  • Members
  • 71 posts
  • LocationCroatia

Posted 07 June 2017 - 10:04 AM

BoomboxLover48 and baddboybill are right.  Can you give us some images from the inside the unit? Bad electrolytics usually leak a little bit or get swollen.



#6 FRizzo17

FRizzo17
  • Members
  • 16 posts

Posted 17 June 2017 - 11:46 AM

I sprayed some deoxit on the solder joints around the volume area on the circuit board. That seemed to fix the issue, however, if i raise the volume too loud i get a humming/bass noise out of left speaker only. Any thoughts about this. Thanks