Jump to content


Photo

5150 deck won't stop trying to engage?


  • Please log in to reply
7 replies to this topic

#1 -GZ-

-GZ-
  • Members
  • 2,228 posts
  • LocationBoom Central

Posted 29 May 2017 - 05:56 PM

As soon as I plug the unit in, there's a noise from the deck like something is spinning or trying to engage. When I hit rewind WITHOUT a tape in, it rewinds for like 3 seconds then stops on its own....and the noise stops simultaneously.....then after about 3 seconds the noise starts up again. Just constantly going regardless of which mode I'm in.

I'm sure this is something common but I never deal with decks. Any help is appreciated.

#2 Reli

Reli
  • Boomus Fidelis
  • 4,626 posts
  • LocationUSA

Posted 29 May 2017 - 05:59 PM

Weird!



#3 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,801 posts
  • LocationChicago, IL

Posted 30 May 2017 - 06:43 AM

I would take the deck out and watch the tape engagement mechanism assisted by solenoids.

I don't think it is just a push and engage tape function like in many decks.

I have two 5150 and they are way hidden in the shelves with my collection. 

 

Some kind of reset needs to be done, or changing the belts with new ones can also help.



#4 baddboybill

baddboybill
  • Boomus Fidelis
  • 10,658 posts
  • LocationIn the middle of nowhere!!

Posted 01 June 2017 - 08:32 AM

The 5150 always seems to need the record bar cleaned but what could be issue here is that micro switch is stuck. These decks are very easy to remove and for most part easy to work on. ;-)

#5 caution

caution
  • Members
  • 1,391 posts
  • LocationHillsboro, Oregon

Posted 01 June 2017 - 01:07 PM

The 5150 doesn't have a solenoid.



#6 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,801 posts
  • LocationChicago, IL

Posted 01 June 2017 - 01:55 PM

The 5150 doesn't have a solenoid.

That is correct Eric!

My mistake.

They are very simple decks to work on. 



#7 skippy1969

skippy1969
  • Boomus Fidelis
  • 4,428 posts
  • LocationBaraboo Wisconsin

Posted 01 June 2017 - 06:32 PM

Send it to me Greg,I'll fix it for you.



#8 -GZ-

-GZ-
  • Members
  • 2,228 posts
  • LocationBoom Central

Posted 01 June 2017 - 06:55 PM

Well look at all these kind offerings. Aren't you fellas the best!
I'm gonna take it apart this weekend and see what I can find. I'm sure it needs new belts and such. I'll clean that record bar like billy says and check the micro switch. If I can't fix her I might just take you up on that offer Skip! Thanks fellas.