Jump to content


Photo

Pioneer SK 550 won't work in play mode!


  • Please log in to reply
11 replies to this topic

#1 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,800 posts
  • LocationChicago, IL

Posted 21 August 2016 - 03:56 PM

I was working on one of my Pioneer SK-550s to fix the deck and noticed all functions work except the take up axle won't turn.

When you hit play the head will engage along with capstan but the take up axle won't turn. I hear a whining noise when you press play that tells me something is not engaging well.

It shuts off in a few seconds because of no rotation on the take up reel. I think the lack of rotation of the take up reel is activating auto stop.

The RW and FF works fine.

I took a good look at the belts and they all look fine to me. but will replace it. 


I saw a flat belt on the pulley and another square belt on the same pulley
That small square belt runs from pulley to a wheel.
There is another belt from the flywheel axle to a drive wheel inside the deck.
I measured the broken counter belt and it looks like 7.0" small square belt.

The belt chart says

FRW 7.1"
SCX 3.5"
SCX 4.3"

So all belts are present and looks good to me but hard to say if one is slipping or not. I can see both the belts on the pulley is not slipping.


The pinch roller also needs to be replaced. The lock on the pinch roller assembly is is not a C clip type. It is a continuous ring washer lock. If that is the case how would I take it off?

Any input for for fixing the deck is greatly appreciated.

I don't have a manual for SK-550. :annoyed:

Attached Files



#2 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,800 posts
  • LocationChicago, IL

Posted 21 August 2016 - 09:29 PM

Somehow I need to make this deck work.  :hmmm:

 

It seems like the drive wheel is not engaging with the take up wheel. The drive wheel engaging action is not visible at all.  :sad: :bang:  :bang:



#3 blu_fuz

blu_fuz
  • Moderators
  • 10,098 posts
  • LocationWI

Posted 22 August 2016 - 07:42 AM

Mine never worked, good luck!



#4 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,800 posts
  • LocationChicago, IL

Posted 22 August 2016 - 08:07 AM

It can REW, FF and all but for play the take up reel won't turn.

 

The inner floating drive wheel somehow don't engage for play.  :bang:

 

I can't get there and see the mechanism because the lead wires are not long enough to connect and watch how it engages.



#5 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,800 posts
  • LocationChicago, IL

Posted 22 August 2016 - 08:10 AM

Mine never worked, good luck!

Thanks Joe!

I want to somehow make this work.

I read your post about it and that of Norm also. In Norm's post the link doesn't work at all. 



#6 baddboybill

baddboybill
  • Boomus Fidelis
  • 10,657 posts
  • LocationIn the middle of nowhere!!

Posted 22 August 2016 - 10:01 AM

Take up reel probably driven by a dry cracked tire. Getting inside is probably best bet to check it out Royce 🤔


Bad Boy Bill

#7 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,800 posts
  • LocationChicago, IL

Posted 22 August 2016 - 10:25 AM

Take up reel probably driven by a dry cracked tire. Getting inside is probably best bet to check it out Royce


Bad Boy Bill

Thanks Bill!

 

But the FF works well. I don't know this tire has to engage or not for FF to turn the take up axle. Unlike many common decks they have many plastic gear wheels in this deck. It looks like a well made deck but like you said I need open it all up and get to those mechanism that engage the tire to the drive wheel.

 

Smaller connection lead wires make it very hard to watch this deck operate when we work on it. It has to go upside down and connect before you can turn it on. Since it goes upside down there is no room to see the action. 

 

I might have to open the flywheel cover and manually turn the flywheel in play position to have a better understanding.

 

I will do that as soon as I get order new belts and all.

 

These are the times we miss old post pictures people working on these SK 500 decks. 

 

I could find none.

 

I will load it with pictures when I start working on it for future reference purpose.

 

I need to get a manual for this also. 

 

I wasted so much time in analogalley looking for a manual. That site is a nightmare for finding manuals.  : I need a few shots of bourbon now. :newyear: :drunk:  :weed:

 

 

 

~Royce



#8 baddboybill

baddboybill
  • Boomus Fidelis
  • 10,657 posts
  • LocationIn the middle of nowhere!!

Posted 22 August 2016 - 10:36 AM

Thanks Bill!

But the FF works well. I don't know this tire has to engage or not for FF to turn the take up axle. Unlike many common decks they have many plastic gear wheels in this deck. It looks like a well made deck but like you said I need open it all up and get to those mechanism that engage the tire to the drive wheel.

I will do that as soon as I get order new belts and all.

These are the times we miss old post pictures people working on these SK 500 decks.

I could find none.

I will load it with pictures when I start working on it for future reference purpose.



~Royce


Well just cuz ff works doesn't mean a thing really🤔 Good luck Royce👍


Bad Boy Bill

#9 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,800 posts
  • LocationChicago, IL

Posted 22 August 2016 - 11:59 AM

Well just cuz ff works doesn't mean a thing really Good luck Royce


Bad Boy Bill

Yes Bill! I understand what you mean. I've seen so many complex decks. In some FF, RW, PLAY all are done with separate motors. Some Nakamichi decks are like that. I have a few of those. I love that design. In many boombox types it is one drive wheel moving on a lever or a cam to make some functions activate. This SK-550 is also cam driven functions on a gear wheel. They all are different in many ways. 



#10 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,800 posts
  • LocationChicago, IL

Posted 22 August 2016 - 12:05 PM

some deck pics

Attached Files



#11 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,800 posts
  • LocationChicago, IL

Posted 22 August 2016 - 02:14 PM

I have fixed the decks of several SK series from 300 series and the, 600, 750 and 757!

 

 

I hope the new belts might solve the problem. I need new pinch roller also for this one. 



#12 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,800 posts
  • LocationChicago, IL

Posted 28 August 2016 - 01:18 PM

Replaced all belts with new ones but that didn't solve the issue.

 

 Took the drive wheel axle off and got a better view of the problem . Like I expected the inside drive gear that moves and engage for FF won't make contact with the drive wheel gear in play mode. Something is not in place to make it happen. Seems like I need to open the top plate under the head assembly to better for better access. 

 

More evasive surgery needed to figure out what causes this.