Jump to content


Photo

Help my Panasonic RX 5005 has lost it’s voice

capacitor amplifier

  • Please log in to reply
8 replies to this topic

#1 dflrm

dflrm
  • Members
  • 4 posts

Posted 01 May 2016 - 05:53 PM

After thirty two years of faithful service I decided to give my Panasonic RX 5005 ,the very first radio I ever owned, some TLC.  I just changed out all the electrolytic capacitor and cleaned all the potentiometers.  Although she still worked pretty good I needed to change the belts so figured now would be a good time to change the caps.  When I ordered my capacitors I did not order enough of one of the sizes so the circuit board got left out while I was waiting for the missing ones to show up.  Since I had to wait for the caps I went ahead and desoldered the potentiometers from the circuit board, took them apart, cleaned, and regreased them all.  While the circuit board was left out I caught my 14 year old god son man handling it even though I had told him to leave it alone.  I finally got the missing caps soldered in and everything seems to work but I have to max out the volume to be able to hear anything.  I am thinking the amplifier chip got fried possibly by static electricity what do you think?  I did use higher voltage ratings on some of the capacitors but I matched the capacitance values and if I replaced one 16 volt with 25 volt they all got replaced with a 25 volt rated caps.  I do not have a schematic for this box does anyone have one?  The amplifier chip says LA4508 and 4K4 below that.  I can find LA4508 chips online but the lower numbers are different from one source to the next and none of them match the 4K4.  
Thanks for any guidance you can give me.
Daniel

 



#2 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 4,803 posts
  • LocationChicago, IL

Posted 01 May 2016 - 06:17 PM

Dan,  Welcome to the best forum on planet Earth.

:hi:  :hi:

 

1. It seems like the grease went to the carbon disc of the potentiometer. Grease as it is a non conductor unlless you used conductive grease.

 

Gently tap on the leads of the potentiometer with a screw driver without shorting it. If you hear noise then I would take it apart and remove any grease on the carbon resistor disc and use deoxit to clean it. 

 

2. Are you sure you connected the cap leads correctly? If the polarity is reversed that might cause issues.

 

 

Other members here will have better suggestions. There are so many Tech Gurus here. :yes:  :yes:



#3 dflrm

dflrm
  • Members
  • 4 posts

Posted 01 May 2016 - 08:47 PM

I used the dielectric grease I use on the steppers in my pinball machines.  I can here am radio very faintly when the volume is turned up all the way. I did try your test but did not hear a difference.  I have not tried FM since the antennae is not hooked up.

I installed capacitors backwards the first time I replaced them on a circuit board.  I learned my lesson with any luck and a little caution I will not have to repeat that lesson again. 

 

Thanks

Daniel



#4 -GZ-

-GZ-
  • Members
  • 2,228 posts
  • LocationBoom Central

Posted 01 May 2016 - 09:24 PM

I'm no guru....there will be a few of those chiming in. But I have to agree with the previous post that your problem is the dielectric grease on the pots. Dielectric grease is non conductive. Pots should be cleaned with silicone based cleaners that clean and evaporate. You might need to take those apart and remove all the grease. Deoxit is the most highly recommended product for pot cleaning.

I just realized I repeated exactly what bbl just said.

#5 ralrein1

ralrein1
  • Members
  • 956 posts
  • LocationShasta County in the real Northern Kalifornia

Posted 01 May 2016 - 09:50 PM

I agree with everything my boombox brothers have told you. I myself am no electrical guru of any kind.I can wholeheartedly recommend Deoxit D5 for rejuvenating volume and tone pots and the like.Get yourself some,you be glad you did.Oh and welcome.

#6 baddboybill

baddboybill
  • Boomus Fidelis
  • 10,658 posts
  • LocationIn the middle of nowhere!!

Posted 03 May 2016 - 09:03 AM

Did you try headphones? Also the headphone jack could be dirty or corrosive causing your issues 🤔


Bad Boy Bill

#7 blu_fuz

blu_fuz
  • Moderators
  • 10,099 posts
  • LocationWI

Posted 03 May 2016 - 10:00 AM

^ I'm finding this to be a real common issue on many of the blasters I am getting lately.



#8 dflrm

dflrm
  • Members
  • 4 posts

Posted 03 May 2016 - 11:03 AM

I ordered some Deoxit and some fader lube both the oil and the grease.  I cannot seem to find my headphone adapter so it looks like I will have to buy another one before I can try the headphone jack. 

Thanks for the list of things to try everyone.  I will keep everyone updated as I try things.



#9 dflrm

dflrm
  • Members
  • 4 posts

Posted 07 May 2016 - 11:08 AM

My Deoxit showed up yesterday as well as my headphone jack adapter.  I desoldered all the potentiometers and took them apart again and cleaned them throughly.  After I cleaned them I sprayed the parts down with the Deoxit for good measure to make sure they were extra clean.  The Faderlube still has not shown up but the Deoxit Fader grease showed up so I used that since according to the container and their website it should work fine.  I used less grease than was originally on there.  I just wiped a thin coat on there with a finger.  After resoldering everything back in I am back where I started.  Just an FYI Deoxit’s Fader grease is a silicon grease with additives which means it is a dielectric grease.  After I read the container I did not have a lot of faith that this would fix my problem since the original grease I used was a silicon grease with teflon but I was desperate enough to try anyway.  I did some reading online and conductive grease is not used in electrical connections because the granulated conductive material causes short circuits.  If you used conductive grease in a volume pot you would be at full volume no matter where you pointed the knob.  Conductive grease is used as an anti-seize grease.  I tried using the headphone jack and I get the same real low volume with volume maxed out.  When using head phones does the boombox use the same amplifer chip?  I think I am really going to have to get a schematic and double check all my work.  The only thing I know for sure at this point is I screwed something up.

Does anyone know where I can get a schematic?  There was a link in the forums but the link is dead.

Thanks
Daniel

 





Also tagged with one or more of these keywords: capacitor, amplifier