Jump to content



Photo

M90 Deck.


  • This topic is locked This topic is locked
4 replies to this topic

#1 prg333

prg333
  • Members (SA)
  • 110 posts

Posted 18 January 2016 - 10:25 PM

Well my friend did a GREAT job on my M-90!  He opened it up and cleaned it completely inside. He had to align the FM band which had 21 pots to adjust. He also got the deck out of the box and cleaned and oiled the motors. New fresh belts were installed. Before I had it someone went in there and bent the metal plate in the back.Took 12 hours to do all that needed to be done. Cost a pretty penny, even with me "friend" discount. 

 

He also made  a tone test tape with a scope.. So he could perfectly adjust the tape deck speed.  

 

The FM sounds fantastic. .Crisp clear with great base. The stereo works now and has a great natural separation.

 

The tape deck sounds great and has NO WOW OR FLUTTER!

But it still has a problem that he could not fix a tape starts playing and plays fine. But when I go to press stop. The deck starts making a chattering sound. The audio goes off but the tape still plays and the meters still move. Deck will not respond to pressing  STOP FF REW PAUSE. Sometimes not even to pushing the power button. One has unplug the the unit or take out the batteries if using on battery power. The the heads will disengage and drop, when it is plugged back in or batteries put back in. Then the deck plays fine. 

It used to happen only when it got to the end of the tape. But now it can happen more at any point during playback . Any thoughts on this problem? Anyone else have it happen?

MyTech friend  who worked on it says 

One of the plastic gears, is slipping and the teeth are worn. He said it is attached to the flywheel so it is impossible to replace. So one would need a ENTIRELY exact same  deck, to fix the problem.. I believe that the M-80 has the same exact auto logic  tape deck as the M-90. So he says if I can get one with a good tape deck and the gears are all good, no wear (like on mine) he CAN swap out the deck from a good M-80 and put in My M-90

 

I would Love  to get a M90 that is Dead but has a good tape deck to replace the cog worth paying some $$ Any help is appreciated 

 

 

 



#2 Superduper

Superduper
  • Boomus Fidelis
  • 6,869 posts
  • LocationSomewhere over the rainbow, USA

Posted 18 January 2016 - 11:53 PM

Suggest probably look at and ensure that the stop solenoid is free and not binding, and that the stop solenoid driver circuit is working properly. 



#3 prg333

prg333
  • Members (SA)
  • 110 posts

Posted 19 January 2016 - 05:19 AM

Suggest probably look at and ensure that the stop solenoid is free and not binding, and that the stop solenoid driver circuit is working properly. 

Okay how hard is that do? Does one have to disassemble a lot



#4 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 5,254 posts
  • LocationChicago, IL

Posted 19 January 2016 - 08:59 AM

It is easy to lose the core pin in the solenoid with the spring. This is connected to a lever that activates the mechanical section. I believe it is hidden under the flywheel cover. I could be wrong! I cannot remember the deck parts well now. 



#5 prg333

prg333
  • Members (SA)
  • 110 posts

Posted 08 February 2016 - 09:29 PM

OK. I wish that they did NOt make the M90 with a auto logic deck. Causes ALL kinds of problems. I have a M70 and the deck is simple and NEVEr gave me any problems