Jump to content


Photo

RX-DT680 Input Button Issues

Panasonic RX-DT680 Buttons

  • Please log in to reply
2 replies to this topic

#1 rci3044

rci3044
  • Members
  • 3 posts
  • LocationIdaho, USA

Posted 10 January 2016 - 08:43 PM

Hello to all!  I am a new member and this is my first post.  I discovered this forum when I Googled "RX-DT680" and found the line-in mod for this wonderful box. 

 

I bought my 680 brand new in 1990, I think.  I pampered it and loved using it as my main CD player.  Eventually I was able to buy other home AV equipment and I gave it to my sister in 1998.  She gave it back to me last week and aside from being very dusty, everything still functions!  All the lights still work, there isn't a scratch anywhere, and it still looks brand new!  The tape player didn't function the first time I hit the play button but after trying fast-forward and reverse a few times, both tape wells had no trouble playing tapes.  I guess things had to loosen up a bit...

 

However, I have bumped into a glitch.  The 3 input buttons (TAPE, TUNER/BAND, CD) on the front center of the unit function but sometimes when I push TUNER/BAND, the CD unit starts up.  Or when I push CD, the display will read "bEEP on" or "bEEP oFF" if I push CD again.  I have reviewed the owner's manual and there is no mention of beep on or beep off.  Does anyone know what this refers to?

 

Second, do my 3 input buttons simply need to be cleaned or is there a more serious issue?  The input buttons function as they should most of the time, but I don't see how the TUNER/BAND button will occasionally turn on the CD player.  I plan to open up the whole unit and clean it out once I get some screwdrivers that are long enough.

 

Please help with these two issues if you can...

 

Thanks!



#2 jimmyjimmy19702010

jimmyjimmy19702010
  • Members
  • 3,161 posts
  • LocationSunny Brisbane, Australia

Posted 10 January 2016 - 11:25 PM

It sounds like you have a couple of buttons activating at the same time. The buttons contained in the front may have become dislodged slightly - This may occur as a result of the unit behind laid face down or the buttons receiving a knock at some stage.

I'd pull the front cover, check for the free movement of these front cover buttons and also spray some switch cleaner in the micro switches behind them.

I've honestly never had a box experience these issues - (sample size of 8).

From memory, the beep on/off is selectable - I can't remember the button sequence to select this option - I'll check my units tonight.

#3 rci3044

rci3044
  • Members
  • 3 posts
  • LocationIdaho, USA

Posted 19 January 2016 - 05:04 PM

Thanks so much for the reply.  I sprayed some cleaner on the switches and cleaned out all the boards with compressed air.  The buttons do function better than they had before. 

 

I'm still uncertain as to what the "bEEP on" or "bEEP off" refers to but this is a small detail and I doubt I'll pursue this any further.





Also tagged with one or more of these keywords: Panasonic, RX-DT680, Buttons