Jump to content



Photo

JVC RC-M90

Tapedeck fails

  • This topic is locked This topic is locked
5 replies to this topic

#1 brown007

brown007
  • Members
  • 4 posts

Posted 04 August 2015 - 08:59 AM

Hi everybody!

 

This is an awesome site and this is my first post.

 

I've had the luck to find an JVC RC-M90 at my grandparents house.

unfortunately, time didn't any good for it.

The radio works fine, same for the EQ and so on.

But the tape deck seems dead and I'm not a tech head.

When I put a tape in it and push play nothing happens, in fact all the buttons for the tape (play, stop, rec, forward, mute,…) do nothing at all. The spindles for the tape deck do not turn.

This is what I've figured out so far:

The "iron bar" (I don't know how it's called) which I've marked on the picture in red does work.

This bar starts to turn when I push the power knob on. Even without a tape in it.

Also the "disc" with a rubber band around does turns.

Something else I've noticed is that the tape heads never touch the tape itself. I guess these heads supposed to "rise" untill it can read the tape.

 

If anyone can help me to fix this of even by getting closer to getting it work I would be very grateful!

 

I know this is probably poorly explained but I'm not English.This took me a while to type! :)

 

Many greeting!

Brown

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Attached Files

  • Attached File  Jvc1.jpg   76.09K   30 downloads
  • Attached File  Jvc.jpg   47.1K   25 downloads


#2 devol-toni

devol-toni
  • Members (SA)
  • 1,419 posts
  • LocationMacedonia, Skopje City

Posted 04 August 2015 - 09:11 AM

Wow, :drool:

I wish I could find the m90 in my grands house  :-D

 

It seems that you have to change the belts on the tape deck with the new one :-) .

 

Welcome here :hi:

Where are you from?



#3 blu_fuz

blu_fuz
  • Moderators
  • 10,503 posts
  • LocationWI

Posted 04 August 2015 - 09:23 AM

Yep, start with the basics and re-belt the cassette deck. Looks like a great start. Gotta love the goodies grandparents have stashed away.



#4 brown007

brown007
  • Members
  • 4 posts

Posted 04 August 2015 - 09:39 AM

Thanks guys!

I'll look into it asap!!

B (from Belgium)



#5 baddboybill

baddboybill
  • Boomus Fidelis
  • 10,991 posts
  • LocationHudson Florida

Posted 04 August 2015 - 11:00 PM

Can't believe how white the speakers look.


Bad Boy Bill

#6 blu_fuz

blu_fuz
  • Moderators
  • 10,503 posts
  • LocationWI

Posted 05 August 2015 - 07:04 AM

The whole picture looks a little washed out, maybe the exposure isn't right - maybe a little darker gray because the case and knobs look really light too.