Jump to content



Photo

Fixing a legend.....


  • Please log in to reply
279 replies to this topic

#271 blu_fuz

blu_fuz
  • Moderators
  • 10,503 posts
  • LocationWI

Posted 19 March 2018 - 03:12 PM

I appreciate that and so glad this ended up being repairable after all that trouble.



#272 blu_fuz

blu_fuz
  • Moderators
  • 10,503 posts
  • LocationWI

Posted 11 May 2018 - 08:41 AM

The 5350 has been my office blaster for the last 2 weeks. Running it for 9 hours a day with no issues.

 

Today is a sad day  : .

 

Only 2 hours into playing it I hear the sound fizzle out and the power light turn off.  :sick: 

 

I quickly got up to resuscitate my dear blaster. Checking switches, power cord, surge protector, everything...... and it's dead  :huh:  :thumbsdown:  :sadno:  :sick:  :sad:  :  :  :sad:  :  :sad:  : .

 

I'm damn near crying at work right now all because of this boombox. I feel sick.

 

 

No simple solution right now until I get back from my weekend away from home. Hopefully it is something easy to fix.



#273 Reli

Reli
  • Boomus Fidelis
  • 5,593 posts
  • LocationUSA

Posted 11 May 2018 - 09:00 AM

That sucks.  Malfunctioning function switch?  If it doubles as the power on/off, sometimes it gets damaged by arcing, as Norm told me.  But if it doesn't respond at all to wiggling it, then maybe it's a blown fuse somewhere?



#274 Superduper

Superduper
  • Boomus Fidelis
  • 6,846 posts
  • LocationSomewhere over the rainbow, USA

Posted 11 May 2018 - 11:59 AM

This model has a really sucky power switch. It’s one of those leaf lever types that’s mounted on the pcb next to the function switch. The function switch has a protruding piece that flips on the power switch lever as glides past it. I’m not saying it’s this for sure, but you’ll want to look at it. This poor design has killed many rx-5350’s. The leaf lever has a tendency to break off as it’s clearly not meant for high cycle use.

Relax Joe, dead Boomboxes are much easier to fix than Boomboxes with mysterious hum or other unexplained gremlins. On the other hand, this switch issue will take some ingenuity to rig up a new replacement.

#275 Hisrudeness

Hisrudeness
  • Members (SA)
  • 2,109 posts
  • LocationSouth East London UK

Posted 11 May 2018 - 02:43 PM

The switch should work something like this.



#276 BoomboxLover48

BoomboxLover48
  • Boomus Fidelis
  • 5,238 posts
  • LocationChicago, IL

Posted 12 May 2018 - 11:29 AM

Check if it is working on batteries.

Check for power on the rails.

 

Like Norm said it will be something simple.... hope it comes back to life again!

 

Good luck!



#277 blu_fuz

blu_fuz
  • Moderators
  • 10,503 posts
  • LocationWI

Posted 14 May 2018 - 09:19 AM

This turned out to be an issue with the power/function switch. The 'leaf' just decided it didn't want to connect anymore while it was playing. I gave it another 1/2 dozen flips and finally heard a 'pop' noise like the power had bumped on for a second and noticed the power light flicker. Fiddled with the switch some more and now it is all back to A-OK normal!

 

Crisis diverted!

 

 

Thanks guys.



#278 Fatdog

Fatdog
  • Administrators
  • 10,806 posts
  • LocationMiddle Tennessee, U.S.A.

Posted 14 May 2018 - 09:43 AM

1d7daf2f48d9f889a591b19305cb712a.jpg



#279 jimmyjimmy19702010

jimmyjimmy19702010
  • Members (SA)
  • 3,559 posts
  • LocationSunny Brisbane, Australia

Posted 14 May 2018 - 11:24 PM

Attached File  D3F16D31-98B9-46AA-A964-150240823201.png   493.97K   2 downloads

#280 metalhandbag

metalhandbag
  • Members (SA)
  • 433 posts
  • Locationuk manchester

Posted 15 May 2018 - 02:55 AM

Result nice one the leaf does cause issues on them .