Jump to content



Photo

JVC RC-828 JW Issue


  • This topic is locked This topic is locked
4 replies to this topic

#1 Jvckingz

Jvckingz
  • Members
  • 5 posts
  • LocationCorydon, Indiana Uniteds states

Posted 16 July 2011 - 11:40 AM

The thing plays great but the speakers cut out until I jiggle the stereo/mono select switch. I'm not sure if the connections just need a good cleaning (This thing really hasn't been used since the 80's). When the speakers cut out they will still play but it'll be at a really low volume or one side wont work till I jiggle the switch again.

#2 teamstress

teamstress
  • Members (SA)
  • 281 posts
  • Locationchicopee, ma, usa

Posted 16 July 2011 - 11:44 AM

Sounds like it needs a shot of Deoxit,contact cleaner. The best way is to open it up and spray the switch directly, a little goes a long way.

#3 Jvckingz

Jvckingz
  • Members
  • 5 posts
  • LocationCorydon, Indiana Uniteds states

Posted 16 July 2011 - 11:49 AM

Sounds like it needs a shot of Deoxit,contact cleaner. The best way is to open it up and spray the switch directly, a little goes a long way.


Ok thanks, I used to have some lying around but god forbid I find it when I need it lol.

#4 monchito

monchito
  • Boomus Fidelis
  • 4,601 posts
  • Locationpythonville florida

Posted 19 July 2011 - 02:16 PM

Sounds like it needs a shot of Deoxit,contact cleaner. The best way is to open it up and spray the switch directly, a little goes a long way.


Ok thanks, I used to have some lying around but god forbid I find it when I need it lol.

:agree: :agree: :agree:

#5 retrohead

retrohead
  • Members (SA)
  • 1,043 posts
  • LocationUnited Kingdom

Posted 10 September 2012 - 04:25 AM

my 828LB has exactly the same issue,i only got her last friday so havent done anything with her yet,but ill be using the contact cleaner on her when i do :yes: do you have any idea how hard the tape deck is to access on this model please? :hmmm: